ПОМОГИТЕ ПОЖАЛУЙСТА РЕШИТЬ ИНФОРМАТИКУ!!! ДАМ 50 БАЛЛОВ!!! Задача 1. Определите, что...

0 голосов
28 просмотров

ПОМОГИТЕ ПОЖАЛУЙСТА РЕШИТЬ ИНФОРМАТИКУ!!! ДАМ 50 БАЛЛОВ!!! Задача 1. Определите, что будет результатом работы следующих программ2 1. s = 0 for n in range (3,8): s = s + 2*n print (s) 2.n = 4 d = n*2 for i in range (1,4): d = d+2*i print (d) Задача 2. Отметьте (выберите из вариантов ответа), что определяется во фрагменте программы: a=int(input()) b=int(input()) for i in range(n): print (‘Enter х’); x= int(input()) if х b:=х if х>а: а:=х; print(b-а); 1) минимальный элемент 2) максимальный элемент 3) разность минимального и максимального элементов 4) разность максимального и минимального элементов Задача 3.Программист написал программу для следующей задачи: Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, заканчивающиеся на 5. Программа получает на вход целые числа, количество введённых чисел не известно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Но он очень торопился и допустил ошибки. Какие ошибки были допущены? Выпишите строки с ошибкой и укажите, как должно быть записано правильно x=int(input('введите число')) max=10000 while x!=0: if x%5==0 and x max=x x=int(input('введите число')) print('максимальное число, оканчивающееся на 5 = ', max) Задача 4 Напишите программу, которая определяет средний рост учащихся в классе (рост каждого ученика выражен целым числом в сантиметрах). Программа получает на вход количество учеников в классе, а затем рост каждого ученика


Информатика (54 баллов) | 28 просмотров
Дан 1 ответ
0 голосов

Ответ:

1) Ответ:50 Ответ:20

2) 3) разность минимального и максимального элементов

3) Ответ: (2 строка) max=10000 , а должно быть max=0 и (4 строка) if x%5==0 and xmax:

4)

lst = []

 

while True:

   try:

       lst.append(int(input()))

   except:

       break

 

if len(lst) == 0:

   print(-1)

else:

   print(sum(lst)/len(lst))

(Это на питоне)

Объяснение:

(22 баллов)
0

Спасибо!