ПАСКАЛЬ Составьте программу, которая заполняет массив 6х6 следующим образом:Б)1 0 0 0 0...

0 голосов
51 просмотров

ПАСКАЛЬ Составьте программу, которая заполняет массив 6х6 следующим образом:Б)1 0 0 0 0 01 1 0 0 0 01 1 1 0 0 01 1 1 1 0 01 1 1 1 1 01 1 1 1 1 1


Информатика (12 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Ответ:

for i:=1 to n do

a[i]:=random(10)+1;

for i:=1 to n do

if not odd(a[i]) then

 a[i]:=a[i]+1;

Объяснение:

ты это имеешь в виду?

(53 баллов)
0

можешь полную написать?

0

вот смотри, первая задача, мне надо в нее впихнуть твои строчки) Uses Crt;
const
N=6;
var
a:array [1..N,1..N] of integer;
i,j:integer;
begin
for i:=1 to N do
begin
for j:=1 to N do
begin
if (i=j) then
a[i,j]:=1
else
a[i,j]:=0;
Write(a[i,j]:2,' ')
end;
writeln
end;
Readln
end.