Электронные часы - 2 2948 ** informatics Электронные часы показывают время в формате...

0 голосов
369 просмотров

Электронные часы - 2 2948 на informatics Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд. Количество минут и секунд при необходимости дополняются до двузначного числа нулями. С начала суток прошло n секунд. Выведите, что покажут часы. Входные данные Вводится целое число n. Выходные данные Выведите ответ на задачу, соблюдая требуемый формат. For example:


Информатика (12 баллов) | 369 просмотров
Дан 1 ответ
0 голосов

#include

#include

#include

#include

#include

#include

#include

#include

#pragma GCC optimize("Ofast")

#define ll long long

using namespace std;

ll digits(ll a){

   if(a == 0)

       return 1;

   ll cnt = 0;

   while(a > 0){

       a /= 10;

       cnt++;

   }

   return cnt;

}

int main() {

   ll n;

   cin >> n;

   ll h = n/3600;

   h %= 24;

   n %= 3600;

   ll m = n/60;

   ll s = n % 60;

   cout << h << ':';</strong>

   if(digits(m) == 1)

       cout << 0;</strong>

   cout << m << ':';</strong>

   if(digits(s) == 1)

       cout << 0;</strong>

   cout << s;</strong>

}

на информатиксе 100 :)

(688 баллов)