Напишите программу ,которая вводит трехзначное число и разбивает его ** цифры . Например...

0 голосов
961 просмотров

Напишите программу ,которая вводит трехзначное число и разбивает его на цифры . Например ,при вводе числа 123 программа должна вывести «1,2,3»


Информатика (43 баллов) | 961 просмотров
Дан 1 ответ
0 голосов

Ответ:

program dich;

var n,x,s,a,b,c: integer;

begin

 writeln('Введите ваше трёхзначное число:');

 readln (n);

 x:=n;

 while (n>0) do

   begin

     n:=n div 10;

     s:=s+1;

   end;

 if s=3 then

   begin

     a:=x div 100;

     b:=(x div 10) mod 10;

     c:=x mod 10;

     writeln (a,',',b,',',c);

   end;

end.

Объяснение:

Программа написана на Pascal.


image
(22 баллов)
0

Надо сделать это в Питон