Напишите программу, которая получает число, а затем вычисляет сумму его цифр. Входной...

0 голосов
36 просмотров

Напишите программу, которая получает число, а затем вычисляет сумму его цифр. Входной сигнал: три цифры номер выход: первая строка представляет собой сумму цифр(в python)


Информатика (47 баллов) | 36 просмотров
Дано ответов: 2
0 голосов

Ответ:

n=int(input("Число: "))

sum = 0

while n>0:

   sum += n%10

   n=int(n/10)

   

print(sum)

Объяснение:


image
(4.0k баллов)
0 голосов

Ответ:

python не знаю, но подскажу.

Объяснение:

тебе нужно найти остаток от деления на 10, потом остаток прибавить к сумме. После, входное число нацело разделить на 10. Оставшейся число пропускаем через эти шаги до того момента, пока оно не будет равняться 0

(38 баллов)