Тема:Программирование циклов с заданным условием продолжения работы. Система:Паскаль...

0 голосов
54 просмотров

Тема:Программирование циклов с заданным условием продолжения работы. Система:Паскаль Сколько раз выполнится данный цикл? Укажите в ответе число. Дана последовательность операторов: a:=1; b:=2; while a+b<8 do begin a:=a+1; b:=b+2; end; s:=a+b Варианты ответов: 1) 0 2) 2 3) 3 2.Чему будет равно значение переменных a,b,s после исполнения этой последовательности операторов ? Выберите правильный ответ. Дана последовательность операторов: Та же,что и 1 первом задании Варианты ответов: 1) a=1; b=2; s=3 2)a=2; b=4; s=6 3)a=3; b=6; s=6 4)a=3; b=6; s=9


Информатика (12 баллов) | 54 просмотров
Дан 1 ответ
0 голосов

Ответ:

Код полностью var

   a, b, s: real;

begin

   a := 1;

   b := 2;

   

   while a + b < 8 do

   begin

       a := a + 1;

       b := b + 2;

       writeln(‘a = ‘, a, ‘  b = ‘, b);

   end;

   

   s := a + b;

   writeln(‘s = ‘, s);

end.

вывод

a = 2  b = 4

a = 3  b = 6

s = 9

Объяснение:

Отсюда видно что цикл прокрутился 2 раза и a = 3  b = 6 s = 9

(26 баллов)