Напишите программу, которая определяет сколь раз входит в строку данное слово. Пример:...

0 голосов
41 просмотров

Напишите программу, которая определяет сколь раз входит в строку данное слово. Пример: чай стол чай печь стул дом чай Ответ: 3. паскаль


Информатика (72 баллов) | 41 просмотров
Дан 1 ответ
0 голосов

Ответ:

uses crt;

const raz=[' ','.',',','?','!'];{/разделители слов, можно добавить}

var s,sl:string;

   i,k:byte;

begin

clrscr;

writeln('Строка:');

readln(s);

writeln('Слово:');

readln(sl);

k:=0;

for i:=1 to length(s) do{идем по строке}

if(s[i]=sl[1])and((s[i-1] in raz)or(i=1)){если символ равен первому символу слова

а перед ним разделитель или начало строки}

and((s[i+length(sl)] in raz)or(i+length(sl)=length(s))){и после слова разделитетль или конец строки}

and(copy(s,i,length(sl))=sl){и все буквы на интервале равны слову}

then k:=k+1;{считаем}

write('Слово ',sl,' встречается ',k,' рз.');

readln

end.

Объяснение:

на каком языке? (В ответе паскаль)

(125 баллов)