Написать программу ** языке программирования Паскаль: Найти наибольшую цифру натурального...

0 голосов
26 просмотров

Написать программу на языке программирования Паскаль: Найти наибольшую цифру натурального числа. С клавиатуры вводится натуральное число. Найти его наибольшую цифру. (Например, введено число 124653. Наибольшая цифра в нем 6).


Информатика (12 баллов) | 26 просмотров
Дан 1 ответ
0 голосов

Var

N,A:integer;

Begin

Write('N = ');Read(N);

A:=0;

While N>0 do

  Begin

  if (N mod 10) > A then A:= N mod 10;

  N:=N div 10;

  End;

Write(A)

End.

Var

N,A,B:integer;

C:boolean;

Begin

Write('N = ');Read(N);

A:=-1;

B:=-2;

C:=false;

While N>0 do

  Begin

  if A=B then C:=true;

  if N>0 then

     Begin

     A:=N mod 10;

     N:=N div 10;

     End;

  if A=B then C:=true;

  if N>0 then

     Begin

     B:=N mod 10;

     N:=N div 10;

     End;

  End;

if A=B then C:=true;

if C then Write('Есть')

else Write('Нет')

End.

(49 баллов)