Программист ** Северном полюсе работал за компьютером в варежках и поэтому мог набирать...

0 голосов
217 просмотров

Программист на Северном полюсе работал за компьютером в варежках и поэтому мог набирать только 0 и 1, а клавиша 0 запала. Сможет ли он набрать число, состоящее только из единиц и при этом кратное заданному N? язык программирования любой Входные данныеПрограмме дано число N (1 ≤ N ≤ 106).Выходные данныеВывести минимальное число, удволетворяющее требованию, или "NO" , если такого числа не существует.Примерывходные данные100выходные данныеNOвходные данные57выходные


Информатика (17 баллов) | 217 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Язык: C++

_________________________

#include

using namespace std;

int main(){

unsigned long long int a, b=0;

cin>>a;

if (a%2==0) {cout<<"NO"; return 0;}</p>

for (unsigned long long int n=1; n<=1111111111111111111; n=n*10+1) {</p>

 if (n%a==0){cout<<n; return 0;}</p>

 ++b;

}

cout<<"NO";</p>

return 0;

}

_______________

Работает, если максимальная длина вводимой программистом последовательности из единиц равна 19. Предполагаю, что этого достаточно.

(3.5k баллов)
0

Ну как сейчас?

0

прошло