Помогите ** языке программирования Pascal нужно написать код благодаря, которому...

0 голосов
32 просмотров

Помогите на языке программирования Pascal нужно написать код благодаря, которому пользователь вводит число N и затем N чисел и программа должна посчитать произведение этих чисел.


Информатика (12 баллов) | 32 просмотров
0

Числа начинаются от единицы?

0

Например N = 5X = 1 * 2 * 3 * 4 * 5

0

Любое число которое введет пользователь, кроме единицы.

0

Если верхняя граница N не определена, то решение будет не таким простым, как это может показаться.

0

Задача школьная и в задании не было обращено никакого внимания на границы значения N. Скорее всего программа не будет использоваться для больших вычислений.

0

Если будут введены большие значения N, то можно заменить тип переменных на int64 или изменить цикл for на while со счётчиком и изменить тип переменных на real

0

Но написать программу под любое значение N не получится, т.к. у всех типов есть границы

0

Задача нахождения факториала большого числа - это классика. :-) Задача решаемая и по своему интересная. Вопрос только в том, действительно-ли была поставлена именно эта задача, или фраза "Любое число которое введет пользователь, кроме единицы" - это преувеличение?

Дан 1 ответ
0 голосов

program raf105;

var n,i,pro: integer;

begin

write('N = ');

readln(n);

pro:= 1;

for i:=1 to n do

begin

 write(i,' ');

 pro:= pro * i;

end;

writeln;

writeln('Произведение: ',pro);

end.

PascalABC 3.4.2

(2.1k баллов)
0

Для небольших значений N - сойдет. Но с любым числом N это работать не будет. Все упрется в классическую задачу написания программы для вычисления факториала числа 100.