Написать программу перевода числа метров в километры.(Используя программу PascalABC.NET)И...

0 голосов
266 просмотров

Написать программу перевода числа метров в километры.(Используя программу PascalABC.NET)И если можно ,то пожалуйста по подробнее!!​


Информатика (12 баллов) | 266 просмотров
Дано ответов: 2
0 голосов

var n:integer;

begin

read(n);

write(n div 1000);

end.

(72 баллов)
0 голосов

Ответ:

program raf105;

var m,km: real;

begin

write('Введите метры: ');

readln(m);

km:= m / 1000;

writeln('Это будет ',km,' км.');

end.

Объяснение:

В километре 1000 метров. Делим количество метров на 1000 и получаем дробное число километров

Тип real принимает числа с цифрами после точки (не целые)

(2.1k баллов)