Даны два целых числа. Составить программу, которая большее число возводит в квадрат, а...

0 голосов
75 просмотров

Даны два целых числа. Составить программу, которая большее число возводит в квадрат, а меньшее увеличивает на 10. Если числа равны, то вывести сообщение "ЧИСЛА РАВНЫ" ​


Информатика (12 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

program raf105;

var a,b: integer;

begin

write('a = ');

readln(a);

write('b = ');

readln(b);

writeln;

if a>b

 then begin

   a:= a*a;

   b:= b+10;

 end

 else  if a    b:= b*b;

   a:= a+10;

 end;

if a=b

 then writeln('ЧИСЛА РАВНЫ')

 else begin

   writeln('a = ',a);

   writeln('b = ',b);

 end;

end.

PascalABC 3.4.2

(2.1k баллов)