** языке паскаль написать программу Дано два массива A и B по 5 элементов. Создать новый...

0 голосов
33 просмотров

На языке паскаль написать программу Дано два массива A и B по 5 элементов. Создать новый массив из 10 элементов, содержащий элементы массивов A и B по такой схеме: A[1], B[1], A[2], B[2],... A[5], B[5].


Информатика (12 баллов) | 33 просмотров
Дан 1 ответ
0 голосов

program raf105;

var  

 a,b:array[1..5] of integer;

 c:array[1..10] of integer;

 i:integer;

begin

writeln('Заполните первый массив:');

for i:=1 to 5 do

 readln(a[i]);

writeln('Заполните второй массив:');

for i:=1 to 5 do

 readln(b[i]);

i:=0;

write('Третий массив: ');

while i < 10 do

begin

 i:= i+2;

 c[i-1]:= a[i div 2];

 c[i]:= b[i div 2];

 write(c[i-1],' ',c[i],' ');

end;

end.

PascalABC 3.4.2

(2.1k баллов)
0

Большое спасибо!