Написать программу с функцией,которая возвращает в основную программу кол-во гласных букв

0 голосов
43 просмотров

Написать программу с функцией,которая возвращает в основную программу кол-во гласных букв


Информатика (53 баллов) | 43 просмотров
0

язык какой?

Дан 1 ответ
0 голосов

program raf105;

var  

 s: string;

 g: integer;

 

function glas(s:string): integer;

const

 glas_list = 'аяоёуюыиэе';

var  

 i,j,res:integer;

begin

 s:= lowercase(s);

 for i:=1 to length(s) do

   for j:=1 to length(glas_list) do

     if s[i] = glas_list[j]

       then res:= res + 1;

glas:= res;

end;

begin

write('Введите строку: ');

readln(s);

g:= glas(s);

writeln('В строке ',g,' глас.');

end.

PascalABC 3.4.2

(2.1k баллов)