Срочно! Напишите программу в паскале с оператором repeat Дано целое число N (>0)...

0 голосов
34 просмотров

Срочно! Напишите программу в паскале с оператором repeat Дано целое число N (>0) используя операции деления нацело и взятия остатка от деления, найти количество и сумму его цифр (N=63)


Информатика (37 баллов) | 34 просмотров
Дан 1 ответ
0 голосов

Ответ:

var n,l,s,k:int64;

begin

read(n);

repeat

k:=n mod 10;

s:=s+k;

l:=l+1;

n:=n div 10;

until n=0;

write(l,' ',s);

end.

Объяснение:

(52 баллов)