Программирование Pascal: Массив нужно заполнить вводом с клавиатуры. Дан целочисленный...

0 голосов
30 просмотров

Программирование Pascal: Массив нужно заполнить вводом с клавиатуры. Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 100 – баллы учащихся выпускного класса, полученные на экзамене по информатике. Напишите программу, которая позволяет найти и вывести количество учащихся, чьи баллы на экзамене выше среднего балла по классу.


Информатика (44 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

var

a:array [1..30] of integer;

i,s:integer;

r:real;

begin

writeln('Введите оценки учащихся(значения от 0 до 100)');

s:=0;

for i:=1 to 30 do

begin

readln(a[i]);

s:=s+a[i];

end;

r:=s/30;

writeln('средний бал=',r:4:2);

s:=0;

for i:=1 to 30 do

if a[i]>r then s:=s+1;

writeln('Количество учащихся с оценками выше среднего=',s);

end.

(3.3k баллов)
0

Спасибо большое!

0

помогите умоляю очень прошу вопрос по ссылке или у меня в профиле буду очень благодарен за помощь https://znanija.com/task/32385568