Написать программу печати квадратов всех натуральных чисел от 1 до n. Паскаль, цикл-for....

0 голосов
47 просмотров

Написать программу печати квадратов всех натуральных чисел от 1 до n. Паскаль, цикл-for. Пожалуйста помогите,очень нужно!!!!!


Информатика (18 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

var n,i:integer;

begin

write('Введите N ');

readln(n);

for i:=1 to n do

writeln(i,'^2= ',sqr(i));

readln;

end.

Если уж совсем просто, то:

var n,i:integer;

begin

write('Введите N ');

readln(n);

for i:=1 to n do

writeln(i*i);

readln;

end.


image
(3.3k баллов)
0

Что это значит?writeln(i,'^2= ',sqr(i));

0

вывести текст i^2= и значение квадрата. вместо sqr(i) можете написать i*i. тоже будет квадрат. На фото результат для n=10