Pascal Написать программу проверяющую есть ли в заданном слове две подряд идущие...

0 голосов
59 просмотров

Pascal Написать программу проверяющую есть ли в заданном слове две подряд идущие одинаковые буквы


Информатика (89 баллов) | 59 просмотров
Дан 1 ответ
0 голосов

program raf105;

var  

s:string;

x:boolean;

i:integer;

begin

write('Введите слово: ');

readln(s);

s:= lowercase(s);

for i:=2 to length(s) do

 if not x

   then x:= s[i] = s[i-1];

if x

 then writeln('В слове есть две подряд идущие, одинаковые буквы')

 else writeln('В слове нет двух подряд идущих, одинаковых букв');

end.

Язык PascalABC

(2.1k баллов)