Задание: составить программу, в которой посчитать кол-во гласных в строке. (в...

0 голосов
56 просмотров

Задание: составить программу, в которой посчитать кол-во гласных в строке. (в pascal)(тема: двумерные массивы)


Информатика (7.9k баллов) | 56 просмотров
Дан 1 ответ
0 голосов

program raf105;

var a:array[1..100,1..2] of char;

glas,s:string;

i,j,sumglas:integer;

begin

glas:='аеёиоуыэюя'; // Перечисление гласных

for i:=1 to length(glas) do

 a[i,2]:= glas[i]; //Заполнение второй строки для гласных

writeln('Введите строку');

readln(s);

for i:=1 to length(s) do

 a[i,1]:= s[i]; //Заполнение первой строки для введённых букв

for i:=1 to length(s) do

 for j:=1 to length(glas) do

   if a[i,1] = a[j,2] //если символ из строки 1 = символу из строки 2

     then sumglas:= sumglas+1; //Прибавление единицы к счётчику

writeln('В строке ',sumglas,' гласных');

end.

(2.1k баллов)
0

integer принимает только числа

0

Будет ошибка

0

Т.к. строка состоит из символов, то в массивах нужно использовать тип char (символьный тип)