Написать программу ** языке Паскаль для решения задачи: По данным сторонам прямоугольника...

0 голосов
50 просмотров

Написать программу на языке Паскаль для решения задачи: По данным сторонам прямоугольника вычислить его периметр, площадь и длину диагонали. Входные данные задать самостоятельно. Для проверки подготовить код программы и результаты ее работы.


Информатика (161 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

var a, b, s, p: real;

begin

write(‘Чему равны стороны прямоугольника: ‘);

readln(a,b);

p:=2*(a+b);

s:=a*b;

writeln(‘Периметр прямоугольника: ‘, p);

write(‘Площадь прямоугольника: ‘, s)

end.

Результат работы:

Чему равны стороны прямоугольника: 2 5

Периметр прямоугольника: 14

Площадь прямоугольника: 10

(654k баллов)