Помогите написать программу в Pascal.Задано число,если оно находится в диапазоне [0,10]...

0 голосов
50 просмотров

Помогите написать программу в Pascal.Задано число,если оно находится в диапазоне [0,10] то данное число возвести в квадрат, если нет, то вычислить квадратный корень из числа​


Информатика (12 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Program zadacha;

var x:integer;

begin

 readln(x);

 if (x>=0) and (x<=10) then writeln(x*x)</strong>

                               else writeln(sqrt(x));

end.

Объяснение:

(321 баллов)