Сделайте ** паскаль без while, а с циклом for пж. Напишите программу, которая в...

0 голосов
41 просмотров

Сделайте на паскаль без while, а с циклом for пж. Напишите программу, которая в последовательности целых чисел определяет количество нечётных чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.


Информатика (23 баллов) | 41 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

var a,i,kol,s:integer;

begin

writeln('Введите последовательность целых чисел, 0 - все введены');

s:=0;

kol:=0;

for i:=1 to 1000 do

begin

readln(a);

if a<>0 then  

begin  

kol:=kol+1;  

if (a mod 2<>0) and (a mod 3=0) then s:=s+1; end

else break;

end;

writeln('Введенных чисел ',kol);

writeln('Нечетных чисел кратных трем ',s);

readln;

end.

(3.3k баллов)