Python и главное чтобы программа работала!! Помогите пожалуйста с домашней работой....

0 голосов
631 просмотров

Python и главное чтобы программа работала!! Помогите пожалуйста с домашней работой. Напишите программу, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.


Информатика (14 баллов) | 631 просмотров
Дан 1 ответ
0 голосов

#a)

print('Input n: ')

n = input()

if int(n) < 0:

   print('Incorrect input')

else:

   sum = 0

   for i in range(int(n) + 1):

       sum += i

   print('Sum is ', sum)

#________________________#

#b)

print('Input n: ')

n = input()

if int(n) < 0:

   print('Incorrect input')

else:

  sum = 0

  for i in range(int(n) + 1):

      sum += i*i

  print('Sum is ', sum)

#________________________#

#c)

print('Input n: ')

n = input()

if int(n) < 0:

   print('Incorrect input')

else:

   sum = 0

   for i in range(0, int(n) + 1, 2):

       sum += i

   print('Sum is ', sum)

#________________________#

#d)

sum = 0

for i in range(10, 100, 1):

   sum += i

print('Sum is ', sum)

(11.3k баллов)