Составьте программу, которая по трем введенным вами числам определит является ли...

0 голосов
70 просмотров

Составьте программу, которая по трем введенным вами числам определит является ли треугольник прямоугольным?


Информатика (12 баллов) | 70 просмотров
0

Числа обозначают длину сторон или углы?

Дан 1 ответ
0 голосов

program raf105;

var a,b,c:integer;

abc: boolean;

begin

write('Введите длины трёх сторон через пробел: ');

readln(a,b,c);

if (a>b) and (a>c)

 then if a**2=b**2+c**2

   then abc:=true;

if (b>a) and (b>c)

 then if b**2=a**2+c**2

   then abc:=true;

if (c>b) and (c>a)

 then if c**2=b**2+a**2

   then abc:=true;

if abc=true

 then writeln('Это прямоугольный треугольник')

 else writeln('Это не прямоугольный треугольник')

end.

Программа написана на языке PascalABC.NET

(2.1k баллов)