Написать программу. Даны три числа. выберите те из них которые принадлежат заданному...

0 голосов
76 просмотров

Написать программу. Даны три числа. выберите те из них которые принадлежат заданному отрезку [e, f]. СРОЧНО!!!


Информатика (21 баллов) | 76 просмотров
Дан 1 ответ
0 голосов

Добрый день,

#include

int main() {

auto a, b, c, e, f;

std::cin >>a >> b >> c; // вводим три числа

std::cin >> e >> f; // вводим промежуток

if (a < f & & a > e) { // проверяем, если число принадлежит отрезку, выводим его

std::cout << a << " " ;</p>

}

if (b < f & & b > e) {// проверяем, если число принадлежит отрезку, выводим его

std::cout << b << " " ;</p>

}

if (c < f & & c > e) {// проверяем, если число принадлежит отрезку, выводим его

std::cout << c << " " ;</p>

}

return 0;

}

Вот ваша программа язык С++

(329 баллов)
0

А мне нужно было на языке Паскаль)

0

язык не указан