Информатика! Нужно составить программу ** языке паскаль. Мама выдала сыну Саше сумму...

0 голосов
71 просмотров

Информатика! Нужно составить программу на языке паскаль. Мама выдала сыну Саше сумму денег Xна карманные расходы. Ежедневно Саша в конце дня подводил итоги своим тратам и заносил их в программу. Требуется определить на сколько дней ему хватило денег и сколько денег осталось.


Информатика (37 баллов) | 71 просмотров
Дан 1 ответ
0 голосов

program raf105;

var mama,sum,rub,day:integer;

begin

write('Какую сумму денег мама выдала сыну? >> ');

readln(mama);

writeln('Введите сумму, которую вы потратили за один день');

writeln('Что бы узнать оставшиеся и потраченные деньги введите "-1"');

sum:=mama;

while sum<>0 do

begin

 readln(rub);

 if sum-rub >= 0  

   then

   if rub=-1  

     then

     begin

       writeln('У вас осталось ',sum,' руб.');

       writeln('Вы потратили ',mama-sum,' руб. за ',day,' дн.');

     end

     else

      begin

        sum:= sum-rub;

        day:= day+1;

      end

    else writeln('У вас недостаточно денег, что бы потратить такую сумму');

end;

writeln('У вас закончились деньги');

writeln('Вы потратили их за ',day,' дн.');

end.

Написано на языке PascalABC.NET

(2.1k баллов)