Даю 15 баллов, помогите написать программу ** Pascal. Условие: Дан массивиз 15 элементов....

0 голосов
25 просмотров

Даю 15 баллов, помогите написать программу на Pascal. Условие: Дан массивиз 15 элементов. 1)Найти сумму чисел элементов являющихся нечётными числами с чётным индексом 2)Найти сумму элементов индексы которых нечётными... Это две задачи. Заранее БОЛЬШОЕ СПАСИБО!!! ​


Информатика (20 баллов) | 25 просмотров
Дано ответов: 2
0 голосов

Ответ:

Объяснение:

вот обе задачи, во втором я так понял, нужно просто нечетные индексы?


image
image
(62 баллов)
0

забыл в конце вывести, перед последним end'ом должно быть write(sum)

0

В какой задаче?

0

в обоих

0

Спасибо

0 голосов

Ответ:

var M:array[0..15]of integer;

     k, i, sum ,inp : integer;

begin

  for  k := 0 to 15 do begin

      writeln('Введите ', k , ' элемент массива:');

      readln(M[k]);

  end;

   

  for i := 0 to 15 do begin

        if (i mod 2 = 0) then  

        begin

            if (M[i] mod  2 = 0) then

            begin

                 sum := sum + M[i];

            end;

        end;

  end;

   

writeln('Вывод : ' , sum - M[0]);

readln;

end.

Объяснение: Ответ к первой части.В общем: в этой программе 0 не считается чётным числом, поэтому 0-вой индекс, даже если его число чётное - не считается . Если вы с этим не согласны то вам всего лишь нужно из этой строчки: writeln('Вывод : ' , sum - M[0]); сделать writeln('Вывод : ' , sum);

Вторая задача :

var M:array[0..15]of integer;

     k, i, sum ,inp : integer;

begin

  for  k := 0 to 15 do begin

      writeln('Введите ', k , ' элемент массива:');

      readln(M[k]);    

  end;

   

  for i := 0 to 15 do begin

        if (i mod 2 <> 0) then  

            sum := sum + M[i];

  end;

   

writeln('Вывод : ' , sum);

readln;

end.

(18 баллов)