Напишите программу, которая бы выполняла переводединиц измерения. За основу можете взять...

0 голосов
104 просмотров

Напишите программу, которая бы выполняла переводединиц измерения. За основу можете взять код, приведенныйв уроке.В программе должны быть:1. Ввод значения – функция input().2. Перевод единиц измерения.3. Вывод значения – функция print().На свое усмотрение, можете усовершенствовать програм-му, дополнив разными функциями. Выбор единиц измеренияна ваше усмотрение. результате будет такая формула:m = n * 1024,где n – число, которое ввел пользователь,а m – результат вычислений.Чтобы выполнить обратное преобразование, т. е. из ме-габайтов в гигабайты, необходимо делить на 1024. Такимобразом, формула имеет вид:m = n ÷ 1024,где n – число, которое ввел пользователь,а m – результат вычислений.Уже минут 30 пытаюсь не получается


Информатика (19 баллов) | 104 просмотров
0

На каком языке писать 67

0

:?

0

PYTHON

Дан 1 ответ
0 голосов
Правильный ответ

Ответ:

Для Python:

def UnitsConversion():

   n = int(input("Введите число для конвертации: "))

   rule = str(input("Нажмите 1, чтобы конвертировать в килобайты и 2, \

чтобы конвертировать в гигабайты: "))

   if rule == "1":

       m = n*1024

       print(m)

   else:

       m = n/1024

       print(m)

Объяснение:

1)Объявляем функцию UnitsConversion (можно назвать как угодно, без параметров в данном случае);

2)Ждем ввода пользователя при помощи input() и сразу же конвертируем ввод в число при помощи int(), чтобы Питон мог совершать над ним мат. операции;

3)Спрашиваем, что нужно сделать: перемножить или поделить. В качестве ответа ждем строку, состоящую из "1" или "2", конвертируется ввод в строку при помощи str(). Если не использовать str(), то по умолчанию input() всегда будет строкой, но чтобы не путаться в данном примере, я использовал str().

4)Проверяем условия: если ввод был 1, то m будет произведение чисел, если не 1, то деление чисел, и также вывод ответа с помощью print().

(102 баллов)
0

там

0

Там где " n = ", выделяет красным и не работает

0

И перед ним тоже : (

0

И перед ним тоже