СРОЧНО, ИНФОРМАТИКА!ПАСКАЛЬ, 8 КЛАСС. Нужно составить программу,которая запрашивает целое...

0 голосов
22 просмотров

СРОЧНО, ИНФОРМАТИКА!ПАСКАЛЬ, 8 КЛАСС. Нужно составить программу,которая запрашивает целое число А < 5 и находит наименьшее натуральное n, при котором A^n >= 50. n вывести на экран. ​


Информатика (62 баллов) | 22 просмотров
Дан 1 ответ
0 голосов

Var a, n:integer;

Begin

Write('Введите число меньше пяти') ;read(A) ;

N:=0;

While exp(ln(A) *n) <50 do begin</p>

N:=n+1;

End;

Write('N=', n) ;

End.

(246 баллов)
0

спасибо большое, но мы ещё функб, если ее так можно назвать, exp не проходили

0

а ты уверен, что там A^n>=50, а не A*n>=50?

0

если там A в степени n, то только так

0

да, там А в степени n, спасибо большое за ответ!