написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным...

0 голосов
83 просмотров

написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после перестановки цифр. В противном случае, вывести выбранное ПК число


Информатика (48 баллов) | 83 просмотров
Дан 1 ответ
0 голосов

var x,x1,x2,x3: integer; //x1- 1 число, х2- 2 число, х3 - 3 число

begin

  randomize;

  x:=random(1000)+10;

  if x div 100 >0 then begin x1:=x div 100;

                                         x2:=(x mod 100) div 10;

                                         x3:=(x mod 100) mod 10;

                                         writeln(x,', ',x3,x2,x1);

                                 end

                         else writeln(x);

end.

     

 

(2.1k баллов)