Написать программу, которая вычисляет среднее арифметическое ненулевых элементов...

0 голосов
127 просмотров

Написать программу, которая вычисляет среднее арифметическое ненулевых элементов введенного с клавиатуры массива целых чисел. Ниже приведен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).Введите элементы массива (10 целых чисел) в одной строке и нажмите .На паскале или на lazarus.-> 23 0 45 -5 12 0 -2 30 0 64 Сумма элементов массива: 184кол-во ненулевых элементов: 7Среднее арифметическое ненулевых элементов: 23.86


Информатика (12 баллов) | 127 просмотров
Дан 1 ответ
0 голосов

var mas:array[1..10] of integer;

   i,kolvo:integer;

   b:real;

   

begin

writeln('Введите 10 целых чисел: ');

for i:=1 to 10 do

begin

read(mas[i]);

kolvo:= kolvo+1;

if (mas[i]=0) then kolvo:= kolvo-1;

end;

 

for i:=1 to 10 do  

begin

b:=mas[i] + b;

end;

 

b:= b/kolvo;

 

writeln('Количество ненулевых чисел= ', kolvo);

writeln('Среднее арифметическое ненулевых чисел= ', b);

 

end.

(26 баллов)