Написать ** языке Python Напишите программу для решения следующей задачи. Ученики 4...

0 голосов
775 просмотров

Написать на языке Python Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите самую низкую температуру за время наблюдения. Если температура опускалась ниже 15 градусов мороза, выведите YES, иначе выведите NO. Программа получает на вход количество дней, в течение которых проводилось измерение температуры N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.


Информатика (12 баллов) | 775 просмотров
Дан 1 ответ
0 голосов

n = int(input())

cold = False

amin = 100

for i in range(n):

   a = int(input())

   if a < -15:

       cold = True

   if a < amin:

       amin = a

print(amin)

if cold:

   print("YES")

else:

   print("NO")

(1.7k баллов)