Напишите программу,которая получает два целых числа и находит их произведение не...

0 голосов
594 просмотров

Напишите программу,которая получает два целых числа и находит их произведение не используя операцию умножения. учтите, что числа могут быть отрицательными.пример :введите два числа: 10 -15, 10*(-15)=-150. Если можно блок схему


Информатика (16 баллов) | 594 просмотров
Дан 1 ответ
0 голосов

var

 a, b, p, i:integer;

Begin

 p:= 0;

 write('Введите a: ');

 readln(a);

 write('Введите b: ');

 readln(b);

 

 if (a < 0) and (b < 0) then

 for i:=1 to Abs(b) do

   p:= p + Abs(a)

 

 else if ((a < 0) and (b >= 0)) or ((a >= 0) and (b < 0)) then begin

   for i:=1 to Abs(b) do

   p:= p + Abs(a);

 p:= p * -1;

 end

 

 else

   for i:=1 to b do

   p:= p + a;

 writeln('Произведение: ', p);

END.

(1.1k баллов)
0

Не продумал момент с отрицательными числами, доделываю

0

Исправил