Информатика помогите!!! задача: Напишите программу ** Паскаль с помощью которой можно...

0 голосов
26 просмотров

Информатика помогите!!! задача: Напишите программу на Паскаль с помощью которой можно вычислить сумму и количество всех ДВУЗНАЧНЫХ ЧЕТНЫХ чисел.(ЦИКЛ WHILE). ЗАРАНЕЕ СПАСИБО)))) я вроде разбираюсь в инфе, но что-то эту задачу никак не решить...​


Информатика (20 баллов) | 26 просмотров
Дан 1 ответ
0 голосов

program raf105;

var a,sum,col:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы узнать результат введите 0');

a:=1;

while a<>0 do

begin

 readln(a);

 if (10

   then if a mod 2 = 0

     then

     begin

     sum:= sum+a;

     col:= col+1

     end;

end;

writeln('Количество чётных двузначных чисел: ',col);

writeln('Их сумма: ',sum);

end.

Написано на языке PascalABC.NET

(2.1k баллов)