Напишите программу, которая вводит два целых числа и находит их произведение, не...

0 голосов
145 просмотров

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
(c++)


Информатика (12 баллов) | 145 просмотров
Дан 1 ответ
0 голосов

#include


int main(){
int a, b, i, c = 0, check = 0;

std::cout << "Введите певое значение:";<br>std::cin >> a;

std::cout << "Введите второе значение:";<br>std::cin >> b;

if(a < 0){
a*=-1;
check = 1;}

for(i = 0; i < a; i++)
if(check = 0)
c += b;
else
c -= b;
std::cout << c << " ";<br>std::cin >> b;

return 0;}

(100 баллов)
0

#include

using namespace std;

int main(){

float i;

for(i=21;i<=35;i++)<br>cout << i << " " << i - 0.6 << endl;<br>
return 0;}