Помогите пожалуйста с информатикой ,10 класс.Задание :Напишите программу вычисления суммы...

0 голосов
49 просмотров

Помогите пожалуйста с информатикой ,10 класс.Задание :Напишите программу вычисления суммы всех элементов массива.Проверьте работу программы на заданном массиве A={7,25,4.5,0,17,61,-10,0,1,-4,22}


Информатика (12 баллов) | 49 просмотров
Дан 1 ответ
0 голосов

var a:array[1..10000] of real;

  i,n:integer;s:real;

begin

  readln(n);

  s:=0;

  for i:=1 to n do

  begin

     read(a[i]);

     s:=s+a[i];

  end;

  writeln;

  write('s=',s);

end.

Проверяем решение

вводим n=11

затем вводим элементы массива 7,25,4.5,0,17,61,-10,0,1,-4,22

получаем ответ s=123.5

(192 баллов)