Помогите написать программу в паскале. задача 3. нужно написать обязательно через циклы,...

0 голосов
43 просмотров

Помогите написать программу в паскале. задача 3. нужно написать обязательно через циклы, без использования процедур и функций, только циклы.​


image

Информатика (12 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

var x,s,p,p1: real;i,n:integer;

begin

readln (x,n);

s:=1;

p:=1;

p1:=1;

i:=2;

while i

begin

  p:=(-1)*p*x*x;write('p=',p);

  p1:=p1*i*(i-1);write('  p1=',p1);

  s:=s+p/p1; writeln('   i=',i,'  s=',s);

  i:=i+2;

  writeln;

end;

if n=1 then write(1) else writeln( 's= ', s);

end.

(192 баллов)