Помогите с паскалем Программирование алгоритмов с циклами (с заранее известным числом...

0 голосов
62 просмотров

Помогите с паскалем Программирование алгоритмов с циклами (с заранее известным числом повторений) при работе с одномерными массивами 4 .Написать программу для нахождения значения переменной S по формуле:


image

Информатика (15 баллов) | 62 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

var p,i, n: integer; s: real;

readln(n);

p:=1;

for i:=2 to n do

   begin

      p:=p*i;

   end;

s:=ln(p);

writeln(s);

end.

(39.5k баллов)
0 голосов

Вводим n и вычисляем с помощью цикла for сумму натуральных логарифмов


image
(192 баллов)