Написать программу ** ЯП Паскаль: из чисел от 10 до 99 вывести те, сумма цифр которых...

0 голосов
52 просмотров

Написать программу на ЯП Паскаль: из чисел от 10 до 99 вывести те, сумма цифр которых равна S (018)..Желательно чтобы в программе были формулы по нахождению p1 и p2 и чтобы программа была выполнена через операторы div и mod,желательно с объяснением


image

Информатика (38 баллов) | 52 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var k,s, p1, p2 : integer;

begin

write('s = ');

readln(s);

for k:= 10 to 99 do

begin

p1:= k div 10;

p2:= k mod 10;

if p1+p2=s then writeln (k);

end;

end.

Пример:

s = 12

39

48

57

66

75

84

93

(194k баллов)