Составьте программу в среде Pascal. Найти сумму 2^2 + 2^3 + 2^4 + ... + 2^10

0 голосов
46 просмотров

Составьте программу в среде Pascal. Найти сумму 2^2 + 2^3 + 2^4 + ... + 2^10


Информатика (41 баллов) | 46 просмотров
Дан 1 ответ
0 голосов

program summa;

var

 res, a, i, j: integer;

begin

 a := 2;

 for i := 2 to 10 do

 begin

   for j := 2 to i do

   begin

     a := 2 * a

   end;

   res := a + res;

   a := 2;

 end;

 writeln(res);

end.

(1.2k баллов)
0

Спасибо огромное!!

0

Пожалуйста

0

Имена переменных можете заменить на свои