ПАСКАЛЬ 1.составить программу которая проверяет четное ли это число 2.составить программу...

0 голосов
96 просмотров

ПАСКАЛЬ 1.составить программу которая проверяет четное ли это число 2.составить программу которая уравнивает два числа a и b 3.составить программу которая проверяет трехзначное ли это число


Информатика (40 баллов) | 96 просмотров
Дан 1 ответ
0 голосов

1)

var

 num: integer;

begin

 writeln('Введите число');

 read(num);

 if(num mod 2 = 0) then  

   write('Число четное')

 else  

   write('Число нечетное');

end.

2)

var

 a, b, i: integer;

begin

 writeln('Введите a');

 read(a);

 writeln('Введите b');

 read(b);

 if (a > b) then

   swap(a, b);

 for i := 0 to  

 b - a - 1 do

   a := a + 1;

end.

3)

var

 num: integer;

begin

 writeln('Введите число');

 read(num);

 if (num div 1000 = 0) and (num div 100 <> 0) then  

   write('Число трехзначное')

 else  

   write('Число не трехзначное');

end.

(3.7k баллов)
0

Здравствуйте,Вы уверены,что это правильно?:)Просто учительница очень строгая

0

('Число четное') в скобках прям так словами и писать?

0

Да

0

@Dudl200,1. Тег SWAP(a,b) не должен был использоваться> Вы где-нибудь в вопросе упоминали, что можно использовать, а что нельзя? Если Вы не ставите ограничения в ответе, то пользователь в праве писать программу так, как угодно ему, но с тем же результатом. К тому же, здесь процедура Swap используется, чтобы не было отрицательного значения (хоть и можно было использовать Abs.

0

2. во-втором пункте в конце ответа не нужно было писать тег write> Опять же, где об этом написано?

0

программа не работает в паскале

0

2?

0

Что значит "не работает"? В каком Pascal? Где запускаете? Какие ошибки выводит?