Pascal.ABC 1 написать программу вводящую случайное число в диапазоне(0,20 ) пока случ...

0 голосов
57 просмотров

Pascal.ABC 1 написать программу вводящую случайное число в диапазоне(0,20 ) пока случ число не станет равно 10 2 Пользователь вводит n. Перебрать числа (подумать да какого числа) в цикле for и вывести все делители n.


Информатика (98 баллов) | 57 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1.

var a:integer;

begin

randomize;

repeat

a:=random(21);

write(a,' ');

until a=10;

end.

Пример:

17 20 12 1 15 5 11 10

2.

var n,i:integer;

begin

readln(n);

writeln('Делители ',n,':');

for i:=1 to n div 2 do

if n mod i=0 then write(i,' ');

writeln(n);

end.

Пример:

24

Делители 24:

1 2 3 4 6 8 12 24

(194k баллов)
0

спасибо большое.

0

Здравствуйте не могли бы помочь с еще 3 задачами?

0

Вот ссылка https://znanija.com/task/31932078

0

можете помочь? можете помочь? https://znanija.com/task/32003818