Напишите программу,которая находит и выводит все трехзначные числа,средняя цифра которых...

0 голосов
138 просмотров

Напишите программу,которая находит и выводит все трехзначные числа,средняя цифра которых равна сумме первой и второй цифр ​


Информатика (12 баллов) | 138 просмотров
Дан 1 ответ
0 голосов

Стандартный алгоритм на плюсах:

НО  мне кажется что в задании есть опечатка и нужно найти числа, где средняя равна сумме первой и третьей.

Навсякий приведу и тот и тот вариант

1) Вариант(КАК В ЗАДАНИИ)

#include

using std::cin,std::cout,std::endl;

int main(){

       for (size_t a=0; a<=9;++a){</p>

               for (size_t b =0;b<=9;++b){</p>

                       for (size_t c = 0; c<=9;++c){</p>

                               if (b == a+b)

                                       cout << a << b<<c << endl;</p>

                       }

               }

       }

return 0;

}

2) Вариант2 (как я думаю)

#include

using std::cin,std::cout,std::endl;

int main(){

       for (size_t a=0; a<=9;++a){</p>

               for (size_t b =0;b<=9;++b){</p>

                       for (size_t c = 0; c<=9;++c){</p>

                               if (b == a+c)

                                       cout << a << b<<c << endl;</p>

                       }

               }

       }

return 0;

}

(150 баллов)
0

Там еще в первом for'e надо size_t a = 1, чтобы были трезначные

0

Хорошо,понял,спасибо)