Написать программу (В ПАСКАЛЕ) , которая вводит с клавиатуры 5 дробных чисел и вычисляет...

0 голосов
75 просмотров

Написать программу (В ПАСКАЛЕ) , которая вводит с клавиатуры 5 дробных чисел и вычисляет их среднее арифметическое.Рекомендуемый вид экрана во время работы программы приведен ниже. Данные, введенные пользователем выделены полужирным шрифтом.Вычисление среднего арифметического последовательности дробных чисел. После ввода каждого числа нажимайте . -> 5.4 ->7.8 -> 3.0 -> 1.5 -> 2.3 Среднее арифмитическое введенной последовательности: 4. 00 Для завершения работы программы нажмите < Enter>.


Информатика (26 баллов) | 75 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

program dgh;

var

a,b: real;

i: integer;

Begin

b:=0;

for i:=1 to 5 do

begin

Write ('->'); readln (a);

b:=b+a;

end;

write('среднее арифметическое введенной последовательности:');

write (b/5:0:2);

Readln;

end.

(1.7k баллов)
0 голосов

var i: integer;

var a  : array[1..5] of real;

begin

for i in [1..5] do

    begin

    write('->');

    readln(a[i]);

end;

writeln((a[1]+a[2]+a[3]+a[4]+a[5])/5:0:2);

end.

(150 баллов)