ПОМОГИТЕ НАПИСАТЬ ПРОГРАММЫ В ПАСКАЛЕ!! ОЧЕНЬ СРОЧНО!!! 1. Построить и записать в виде...

0 голосов
47 просмотров

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММЫ В ПАСКАЛЕ!! ОЧЕНЬ СРОЧНО!!! 1. Построить и записать в виде программы алгоритм вычисления суммы квадратов десяти произвольных чисел, водимых с клавиатуры в процессе выполнения программы. 2. Составить программу нахождения суммы чётных чисел, находящихся в промежутке от 26 до 88. 3. Вводятся 14 чисел. Определить, сколько среди них положительных (включая 0) и сколько отрицательных. (Числа вводятся в одну переменную в цикле).


Информатика (372 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Задача №1

var i, sum, x: integer;        

begin  

sum := 0;   //начальная сумма

 

for i := 1 to 10 do   //счётчик до 10

begin  

 write('Введите число ', i ,': ');  

 readln(x);  

 sum:= sum + sqr(x);  //к сумме прибавляем квадрат введенного числа

end;  

 

writeln('Сумма квадратов чисел = ',sum);  

 

end.

Задача №2.

var i, sum: integer;  

     

begin  

sum := 0; //начальная сумма

 

for i :=  26 to 88 do //счётчик от 26 до 88

 begin

   if i mod 2 = 0 then //проверка на чётность, если остаток от деления равен 0, то число чётное

    sum:= sum + i; //к сумме прибавляем число

  end;

   

  write(sum);

 

end.

(140 баллов)