Дано натуральное число. Написать программу, которая определит является ли число...

0 голосов
38 просмотров

Дано натуральное число. Написать программу, которая определит является ли число двузначным. Ответ: True или False и является ли четной сумма его цифр.ПОЖАЛУЙСТА СРОЧНО Даю 50 баллов.​


Информатика (77 баллов) | 38 просмотров
Дано ответов: 2
0 голосов

Python:

a = int(input())

s = 0

print("True") if len(str(a)) == 2 else print("False")

for i in str(a):

  s+=int(i)

print("сумма цифр чётная") if s % 2 == 0 else print("сумма цифр не чётная")

(54 баллов)
0

Зачем явно указывать тип int к переменной i?

0

потому что изначально это символ

0

input возвращает строку в Python 3.x

0

Неправильно прочитал. Почему нельзя удалять или изменять комментарии?

0

Изначально это целочисленное значение:a = int(input())То, что Вы в условии использовали функцию str(a) - ещё не делает эту переменную строкой, поскольку в функцию str() передаётся не ссылка на переменную a, а копия.

0

дак речи и не шло, о том что переменная a делается строкой

0

Тогда каким образом переменная 'a' вначале становится символом?

0

вы спросили про переменную i )

0

Слепой я)

0 голосов
  1. var
  2.  number: integer;
  3. begin
  4.  Readln(number);
  5.  if (number >= 10) and (number <= 99) then</li>
  6.    begin
  7.      Writeln('True');
  8.      if (number div 10 + number mod 10) mod 2 = 0 then
  9.        Writeln('Сумма цифр чётна.')
  10.      else
  11.        Writeln('Сумма цифр нечётна.');
  12.    end
  13.  else
  14.    Writeln('False');
  15. end.
(5.6k баллов)