Составить программы ** языке Паскаль для решения задач. Задача 1. Вычислить площадь...

0 голосов
22 просмотров

Составить программы на языке Паскаль для решения задач. Задача 1. Вычислить площадь прямоугольника и длину его диагонали, если стороны соответственно имеют длины 5 и 8 см. Задача 2. Написать программу, которая вычисляет площадь треугольника s, со стороной a=10 и высотой h=15. Задача 3. Вычислить площадь трапеции с высотой h=8 и основаниями a=10 и b=20.


Информатика (3.5k баллов) | 22 просмотров
Дан 1 ответ
0 голосов

Задача 1.

var

a,b,S,d: real;

begin

a:=5;

b:=8;

d:=sqrt(sqr(a)+sqr(b));

S:=a*b;

writeln('d = ',d);

writeln('S = ',S);

end.

Задача 2.

var

a,h,S: real;

begin

a:=10;

h:=15;

S:=1/2*a*h;

writeln('S = ',S);

end.

Задача 3.

var

a,b,h,S: real;

begin

a:=10;

b:=20;

h:=8;

S:=1/2*(a+b)*h;

writeln('S = ',S);

end.

(6.1k баллов)
0

а разве не Integer?

0

можно и integer)

0

Хорошо, спасибо

0

я чтоб потом не замарачиваться просто сразу взял реал