Напишите программу для решения этого уравнения ** языке паскаль (B^2/1,44*a^2) +0,82...

0 голосов
27 просмотров

Напишите программу для решения этого уравнения на языке паскаль (B^2/1,44*a^2) +0,82 Разделить это все на a корень из 256/BA


Информатика (31 баллов) | 27 просмотров
0

можете прислать картинку,не понятно немного

Дан 1 ответ
0 голосов

Ради тебя мне пришлось разобраться в паскале

program lol;

var

   x,y,a,B: single;

begin

   writeln('Введите значение b: ');

   readln(B);

   writeln('Введите значение a: ');

   readln(a);

   y := sqrt(256/B*a);

   x := (sqr(B)/1.44*sqr(a)) +0.82;

   x := x / y;

   writeln('Ответ: ', x);

end.

Если тебе нужно разделить уравнение на "(√256) / B * a", то замени строку "y := sqrt(256/B*a); " на стоку "y := sqrt(256) / B * a". А если тебе нужно именно "√256 / B * a", то ничего заменять не нужно.

(173 баллов)
0

"Ради тебя мне пришлось разобраться в паскале" - вхвх)

0

x := x / y; в этой строке перепутали "x" с "a" ;)

0

Мне кажется автор сделал опечатку с буквой "а", а имел он ввиду "Разделить это всё на корень из 256/B * a"

0

Я имел ввиду а корней из 256