Написать программу ** С++

0 голосов
28 просмотров

Написать программу на С++


image

Информатика (35 баллов) | 28 просмотров
0

#include using namespace std;int main (){ int i,j,a,M,p,m[i][j]; setlocale (LC_ALL, "Russian"); //Исходная матрица 5x5 cout<<"Введите размерность: "; cin>>M; cout<cout<<"Матрица:"<for(i=0;i{ cout< for(j=0;j { a++; m[i][j]=a; cout< } } //Итоговая матрица 5x5 for(i=0;i{ cout< for(j=0;j //Замена правой и левой половины массива { p=m[i][j]; m[i][j]=m[i][M-1-j]; m[i][M-1-j]=p; } } for(i=0;i{ cout< for(j=0;j { cout< } } return 0;}Что-то попытался написать, замена работает не так как надо.

0

Если не так как надо так зачем добавлять решение?)

0

Даже в коменты)

Дан 1 ответ
0 голосов

#include

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int m, n, a;

cout<<"Введите размеры массива (строки, столбцы) ";</p>

cin>>m>>n;

if (n%2==0)a=n/2; else a=n/2+1;

int arr[m][n];

cout<<"Введите элементы массива"<<endl;</p>

for (int i=0; i

 for (int j=0; j

 cin>>arr[i][j];

for (int i=0; i<=m; ++i)</p>

 for (int j=0; j

 int buf=arr[i][j];

 arr[i][j]=arr[i][j+a];

 arr[i][j+a]=buf;

 }

for (int i=0; i

 for (int j=0; j

 cout<<arr[i][j]<<" ";</p>

 cout<<endl;</p>

}

}

(3.5k баллов)