Написать программу ** языке C# : cчитая, что Земля – идеальная сфера с радиусом равным...

0 голосов
151 просмотров

Написать программу на языке C# : cчитая, что Земля – идеальная сфера с радиусом равным 6350 км, определить расстояние до линии горизонта от точки с заданной высотой на Землей.


Другие предметы (12 баллов) | 151 просмотров
Дан 1 ответ
0 голосов

const

 r=6350;

var

 h,l: real;

begin

 write('Введите значение высоты h (км): ');

 readln(h);

 writeln('До линии горизонта ',sqrt(sqr(r+h)-sqr(r)):0:3,' км');

 readln;

end.

Вот на паскале суть та же,введи переменные подставь в формулу и всё

(18 баллов)